10 – Solved: No usable version of the libssl was found On Linux – Azure DevOps Agents

In one of the CentOS CORE Linux installation, while I was trying to setup Azure DevOps agents, I came across following error:

No usable version of the libssl was found.

After looking for a lot, figured that the Azure DevOps Build and Release Agents which I was using uses OpenSSL 1.0 and on my OS I have Open SSL 1.1. One solution was to downgrade OpenSSL on my system, but that can create issues with other software. Much later figured that I was using older version of Azure DevOps Build and Release agents. We need to use Azure DevOps Build and Release agent which has version greater then 2.153.1

You can get latest version from below URL:

https://github.com/microsoft/azure-pipelines-agent

About the Author

Leave a Reply

Your email address will not be published. Required fields are marked *